3min

“This API project is not authorized to use this API”

This message is displayed when you have not enabled one or more of the Google Maps APIs on your project which are required for the plugin to function.

The Places API is required for address fields – the autosuggest will display this message if you do not enable the Places API.

The Geocoding API is required for adding and editing marker addresses – the plugin cannot translate addresses into coordinates without the Geocoding API.

API project not authorised to use this API error message
API project not authorised to use this API error message

This may appear as Geocode failed for the following reason: fail in older versions of the plugin / Pro add-on.

Geocode failed for the following reason: fail error message
Geocode failed for the following reason: fail error message

You must enable the following APIs for the plugin to be functional:

  • Google Maps JavaScript API
  • Google Maps Geocoding API
  • Google Maps Places API

Please refer to our documentation on Creating a Google Maps API key for full instructions on setup and installation.



Updated 28 Jun 2022
Did this page help you?
Yes
No